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This chapter introduces the mixer circuit and shows all the basics
of DC simulations, including a family of curves and device biasing
calculations.

Lab 2: DC Simulations
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OBJECTIVES

• Build a symbolized sub-circuit for use in the hierarchy

• Create a family of curves for the device used in the mixer

• Sweep  variables, pass parameters, and the plot or list the data

• Use equations to calculate bias resistor values from simulation data

NOTE about this lab: This lab and the remaining labs will use the BJT mixer to
demonstrate all types of simulations.  Regardless of the type of circuit you design, the
techniques and simulations presented in these labs will be applicable to many other
circuit configurations.

PROCEDURE

The following steps are for creating the mixer BJT sub-circuit with package parasitics
and performing the dc simulations as part of the design process.

1. Create a New Project and name it: mixer

2. Open a New Schematic Window and save it as: bjt_pkg

3. Setup the BJT device and model:

a. Insert the BJT generic device and model: In the schematic window,
select the palette: Devices–BJT.  Select the BJT-NPN device and insert
it onto the schematic.  Next insert the BJT Model (model card with
default Gummel Poon parameters).

Device: Generic BJT

Model card: Gummel-
Poon parameters
appear on the screen.

NOTE: As shown, the model instance
name (BJTM1) must match the
BJT_NPN Model  = BJTM1.
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b. Double click on the model. When the dialog appears, click Component
Options and in the next dialog, click Clear All and OK. This will
remove the parameter list from the schematic.

c. Assign Forward Beta = beta. Double click on the model card you just
inserted.  Select the Bf parameter and type in the word beta as shown
here. Also, click the small box: Display parameter on schematic for
Bf only and then click Apply. The numerical value of beta will be
assigned in the next steps.

d. Type in the value of Vaf (Forward Early Voltage) as 50 and display it by
clicking Apply and OK. This will make the dc curves more realistic.

e. Click OK to dismiss the dialog box with these changes.

f.  For the BJT device or any component, you can also remove the
unwanted display parameters (Area, Region, Temp and Mode) by editing
it in the same way.

First, click on
Component Options
to clear the entire
parameter display.

Afterward, click
here to display an
individual value.
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4. Build the rest of the subcircuit

The picture here shows the completed subcircuit.  Follow the steps to build it or
simply build it as shown:

NOTE: Connect the components together or
wire them as needed.

a. Insert the package parasitics L and C: Insert three lead inductors (320
pH) and two junction capacitors (120 fF).  Be sure to use the correct
units (pico and femto) or your circuit will not have the correct response.
Also, add some resistance R= 0.01 ohms to the base lead inductor and
display the desired component values as shown.

b. Insert port connectors: Click the port connector icon (shown here)  and
insert the connectors exactly in this order: 1) collector, 2)
base, 3) emitter.  You must do this so that the connectors have the
exact same pin configuration as the ADS BJT symbol. Edit the port
names – change P1 to C, change P2 to B, and change P3 to E.

c. Clean up the schematic: Position the components so the schematic
looks organized – this is good practice.  To move component text, press
the F5-Key and then select the component. Use the cursor to position
the text.

Add Wire icon.

NOTE: You must
number the
ports (num=)
exactly as
shown or the
device will not
have the correct
orientation.
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5. Create a symbol for the sub-circuit

There are three ways to create a symbol for a circuit: 1) Use a default
symbol, 2) Use a built-in symbol (a standard symbol), or 3) Create a new
symbol by drawing one or modifying an existing one.  For this lab you will
use a built-in bjt symbol which looks better than the default three-port
symbol. The following steps shows how to do this:

a. To see the default symbol, click: View >
Create/Edit Schematic Symbol.  The symbol
page will replace the schematic page and a dialog
will appear.  Click OK to use the defaults.

b. Next, a rectangle or square with three ports is
generated:

NOTE: You will be replacing the default symbol with a built-in
BJT symbol in the next steps. As you do, you must assign the
pin (port) numbers exactly as shown to match the built-in
symbol for the emitter, base, and collector.

c. To change the symbol to a built-in symbol that looks like a
transistor, delete the entire symbol you just created: Select > Select
All. Then click the trash can icon to delete the symbol.

d. Return to the schematic: View > Create/Edit Schematic.
Now click File> Design Parameters.  In the General tab,
there is a Symbol Name parameter list.  Click the arrow and
select: SYM_BJT_NPN.  Also, Change the component
instance name to Q.

File >Design Parameters
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e.  Set beta as a pass parameter: To do this, click the Parameters tab.  In
the Parameter Name area, type in beta and assign a default value of 100
by clicking the Add button. Be sure to click the Display button as
shown in the picture. Click the OK button at the bottom (not shown
here) to save the new definitions and dismiss the dialog.

f. In the schematic window, Save the design to make sure all your
work is save and close the window. You now have a sub-circuit
that will be available for use in other designs and other projects.

6. Create another circuit for DC simulations

a. Open a new schematic from the Main window and save it as: dc_curves.
This will be the upper level circuit.

b. Click on the Library list icon and the
library browser will appear.
Select the mixer project and you
will see the bjt_pkg circuit listed
as an available component.

The term beta is now
recognized as a
parameter of this circuit.
Its value can now be
passed (assigned) from
another circuit as you
will see.
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c. Select the bjt_pkg component and the npn transistor symbol will be
appear on your cursor.  Click in the dc_curves schematic to insert the
bjt_pkg.  You can now close the library window and save the
dc_curves design (good practice to save often).

7. Set up a dc curve tracer

For this step you will use a template. ADS built-in templates make it easier to set up
the simulation after the schematic is built.  In this case, the dc curve tracer template is
set up to sweep VCE within incremental values of base current IBB.

a. On the schematic, click File > Insert Template and select the
BJT_curve_tracer to insert it. Click OK and it will appear on your
cursor - to insert it, click near your bjt_pkg symbol.

Click to
insert the
template.
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b. With the curve tracer template inserted, wire the circuit together so it
looks like the shown here.  Note that you can move the component text
using the F5 key so that the schematic looks good.

NOTE: If you did not use this Template, you would have to insert every component
(the V_DC source, the I_Probe, the I_DC source, etc.) one at a time. Also, you would
have to assign and set up the variables (IBB, VCE) for the swept simulation.

c. Set the Parameter Sweep IBB values: 1 uA to 11 uA in 2 uA steps.
Parameter Sweep components are available in all simulation palettes. Set
the DC simulation controller SweepVar VCE: 0 to 5 in 0.1 steps.
Notice that the VAR1 variables VCE and IBB can be used as is because
they only initialize the variables but it is best to use reasonable values.

Parameter sweep used for
multiple variable sweep. Note
that “DC1” is the name
(SiminstanceName) of the
simulation controller.

VarEqn is required to
initialize  variables .

Only one variable can
be swept in a
simulation controller.

F5Wire
Icon Keyboard F5 is

a Hot Key for
moving
component text
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8. Name the dataset and run the simulation

a. Click Simulate >  Simulation
Setup. When the dialog appears,
type in a name for the dataset
dc_curves as shown.

b. Click Apply and Simulate.

c. After the simulation is finished, click
the Cancel button and the setup
dialog will disappear. If you get an
error message, check the simulation
set up and repeat if necessary.

9. Display the results, change beta, and resimulate

a. Click the New Data Display icon (shown here).  Insert a
rectangular plot and add the IC.i data.  Note that voltage
VCE is the default X-axis value. The results should look
similar to the “beta=100” plot shown here.

b. On the schematic, change the value of beta = 144. The value will
automatically be passed down to the sub circuit that you set up in the
previous steps.  Simulate again and notice the change as shown here.
NOTE: You will use beta =144 for the remainder of the labs.
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c. Insert a marker on the
dc_curves trace (as shown
here), where the initial
specification of 1 mA at VCE
corresponds to about 7 uA of
base current.

d. Insert a list (click the icon).

e. Select collector current IC and
add it . If the list is in table
format as shown (box with X
across it), edit or double click the list and check the box, Suppress
Table Format and OK.  Then scroll through the data.

The marker
text can be
selected
and moved.

2V VCE at IBB of 7 uA  shows
about 1 mA of collector
current. Use the scroll button
on the top of the display

Use the scroll buttons to rapidly move
through the data at these increments:

to the end, a page, or one data line.

List Icon
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DC Bias DESIGN CONSIDERATION: When the final circuit is constructed, the LO
drive will shift the current slightly higher and this means that the operating point can
be a little lower if desired.   In addition, a current limiting collector resistor RC will be
required and that will lower the voltage across VCE.  Knowing this, it is reasonable to
assume that VCC of 2 volts will be divided with a voltage drop of about 0.5V for RC
with the remaining 1.5V across the device VCE.

10.  Create a new design to calculate bias values

The next steps will sweep only base current for a fixed value of VCE at 1.5 volts. This
will allow you to determine values of base-emitter voltage VBE that can be used to
calculate the bias resistor values.

a. Save the dc_curves schematic. Next, save it with a new name as
follows: click File > Save As and when the dialog box appears, type in
a new name: dc_bias.  Now, you have three designs in the networks
directory: bjt_pkg, dc_curves and dc_bias.

b. If only one variable is swept, it is more effective to sweep it in the
Simulation controller and not in a Parameter sweep. Therefore, delete
the Parameter Sweep.  Refer to the schematic here to: 1) edit the DC
controller to sweep IBB: 1uA to 11 uA in 1 uA steps, 2) set Vdc =
1.5V, and 3) remove VCE from the VarEqn by editing it (double click)
and using the Cut button to remove VCE as a variable.

c. Insert a node name to allow you to get simulation data from a node on
the schematic. Click the icon or use the command: Component >
Name Node. When the dialog appears, type in the name VBE and click
on the node at the base of the transistor.

Name Node icon for
defining VBE node
(VBE data to dataset).

VCE is cut from the VarEqn
and IBB is now swept in the
DC controller,

Administrator
Highlight

Administrator
Highlight

Administrator
Note
这是一种合理的假设，假设集电极直流偏置电压被分为两个部分，一个是加在限流电阻RC上的，另一部分为VCE。在此例中，假设分在限流电阻上的电压为0.5V。
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d. Save and Simulate: Save the new design by clicking the save icon –
this is always good practice.  Next, check the dataset name: Simulation
> Setup) as in the previous simulation.  Be sure it appears as: dc_bias
and then Simulate.

11.   Display the data (dc_bias) in a list

In this step, you will use the same data display window that contains the dc_curves
data.  In fact, you can plot numerous datasets in the display but you must explicitly
define (dataset name..) the data to be displayed.

a. In the current Data Display window, notice that the default dataset is
dc_curves. This is OK.  However, if you change the default to
dc_bias, you will see that the plot becomes invalid because the data is
not the same array size as the two dimensional one. This is normal. Try
this now as shown and then set it back to dc_curves.

b. Now, in the current Data
Display window, make
room for the new data by
using the zoom and view
icons.  Then insert a
new list.

c. When the list dialog box
appears, select the
dc_bias dataset and, add
VBE and IC. You should
get results similar to those
here where IC is very
close to 1 mA.

Plot becomes
invalid when
default dataset is
changed.
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d. Draw a box around the values of interest as shown here.  To do this,
click the rectangle icon from the tool bar and draw it on the list. This is
one way to highlight the data. Also, the data display window by using
Save As and giving it a name like: dc_data.

12. Write an equation to calculate Rb

a. On the data display,
insert an equation by
clicking on the equation
icon and then clicking
in the data display
window:

b. When the dialog appears, type in the equation as shown by typing and
using the Insert button.  First, select the dc_bias dataset in the upper
right (circled).  To write the equation type the first part only: Rb = (1.5 -
and select VBE and click <<Insert<<.  Then type in the parenthesis
and division sign: )/.  Then insert IBB in the same way and click OK.  If
the equation is RED (invalid), repeat the step or ask the instructor for
help.

NOTE: minus sign
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IMPORTANT NOTES on writing equations

Equations that operate on data can either be explicit or generic:

The difference in these two equations is in the data being referenced, especially the
default dataset in the case of the generic equation.  Also, note that equations and
data are CASE SENSITIVE.

c. Verify how the generic equation described above will work.  Be sure the
data display shows dc_curves as the default dataset.  Now, insert
another equation and type it in as shown (generic version):

Rb1 = (1.5 - VBE) / IBB.    After you click OK and it will be red (invalid)

d. Now, change the default dataset to dc_bias (at the top of the
display) and verify that it is valid.

Now, continue with the design by calculating the collector resistor.

e. Write an equation for resistor Rc.   You should be able to do this
based on what you learned in the previous steps.

Generic Equation: When no
dataset is specified, the
equation applies to the
default dataset.

Explicit Equation: A
specific dataset is
referenced: name..

Equation is black (valid)
because the default dataset
corresponds to the equation..

Administrator
Note
这个是集极电阻的计算公式吗？好像不对，应该是发射极的哦？

这个是集电极电阻的计算公式，因为这个放大器的直流通路构造不一样！
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f. List the values Rb and Rc.
Insert a List and when the
first dialog appears, select
Equations by clicking the
arrow.  Then Add Rb and Rc
and click OK.

g. When the list appears, you will then see a table of values for Rb and Rc
that correspond to the value of IBB.  As a rule, you always get the
independent variable (here IBB) when you list or plot data.

h. Increase the size of a display (if you see dots …after the entries), by
dragging the corner of the list. If dots appear after a number or name, it
indicates there is more data and you should
increase the size of the list or plot.

i. Draw a box (rectangle around the desired values to read it easier.  Then
edit the list (double click) and select Plot Options.  Now, type in a title
and change the format as shown by using the More button if desired.

j. Be sure to save the display (.dds file). With these values of Rb and Rc,
the next step is to bias the device and test the bias network.
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13.   Set up a new design to test the bias network

For this step, you will create the schematic design without using a template.  During
this process you will learn some efficient ways to do this.

a. Open a new schematic from the existing one, using the File > New
command or the icon and name it: dc_net.  Notice that this dialog allows
you to name the new design and gives you other options.

b. In the new schematic (dc_net), insert your sub circuit bjt_pkg by typing
in the name in the component history list:

c. Set the value of beta to: 144

d. Goto Lumped
Components palette and
insert a resistor as the
base resistor. Notice that
“R” appears in the history
list when you do this.

In Schematic Window:

Type in the name of the desired
component or sub circuit (case
sensitive) here and press Enter.
The component is ready to insert.



    Lab 2: DC Simulations

2-17

e. Insert the collector resistor and rotate it: put the cursor in the history list
“R” and press Enter.  Immediately, when the resistor is attached to your
cursor, click the –90 rotate icon shown here and the component will
increment 90 degrees – then insert it.

f. Insert a current probe (I_Probe) from the palette or type it in.
Connect it to the top of the collector resistor.

After you connect the
component, you can
drag it and it is
automatically wired.

This icon is only active
when you first select a
component.  To rotate
existing components, use
the other icon.
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g. Finish building the circuit as follows:

• Rename and assign resistors: Rb = 100 K ohms and Rc = 470 ohms.

• Rename the I_Probe: IC

• Insert V_DC supply set at 2 V from (Sources-Frequency Domain palette).

• Insert a node name at the collector as VC.

• Wire the circuit and organize it.

NOTE on Name Node: To remove a named node, click Edit > Component >
Remove Node Name or you can rename the node with a blank (click the icon and try
it). This step is to show how to remove a node name – you may need it later on.

h. Insert a DC simulation controller (Simulation-DC palette).

No editing or setup is required
because no variables are being
swept. DC simulation controller
will recognize the DC source.

Change from
I_Probe to IC

Insert the cursor
and type over to
rename R2 to Rc
and enter 470
Ohms.
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14.  Simulate and verify the bias network conditions

For this you do not need to display the data.  Instead, you will simply annotate the
schematic to verify that IC meets the 1 mA specification and that bias design
consideration (described earlier) is accurate.

a. Press the F7 keyboard key and the simulation will be launched with the
dataset name that is the same as the schematic – this is the default.  You
can verify this by reading the status window:

b. Annotate the current and voltage at the nodes.  Click on the menu
command: Simulate > Annotate DC Solution. Now you should see
the voltage and currents at the nodes.  Be sure that you have about 1 mA
of collector current with VCE about 1.5 V.  If not, check your work.

VCE is 1.5 volts

IC is 1 mA
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15.   Sweep Temperature

a. Edit the DC controller – select it and click the edit icon.

b. In the Sweep tab, enter the ADS global variable temp (default is
Celsius) as shown here and enter the sweep range: -55 to 125 @ 5
step.  Also, in the Display tab, click the boxes to display the annotation
on the controller – click Apply to see it and OK to dismiss the dialog.

c. Set the simulation dataset name to
dc_temp, click Apply to assign that
dataset name, and then Simulate.
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d. Plot the results in a rectangular plot as VC vs temp -  you should be
able to do this as shown:

The plot should look like the one shown here: collector voltage decreases as the
temperature increases.  You can use this temperature sweep method for any
simulation in the future.
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EXTRA EXERCISES

1.  Plot current  (probe) vs. temperature.

2.  Try these commands:

a. Select the bjt and click the command: Edit > Component > Break
Connections.  Reinsert the bjt and see what happens.

b. Spend a few moments experimenting with the other Simulation menu
commands: Highlight Node and Detailed Device Operating Point. These
are only available after a dc simulation.

    c. Go to the data display: Use the right mouse button and experiment
with the selections.

2. Replace the Gummel-Poon model card with another model (Mextram) and
resimulate.  Afterward, compare the results.

Administrator
Highlight

Administrator
Highlight
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联系我们： 

※ 易迪拓培训官网：http://www.edatop.com 

※ 微波 EDA 网：http://www.mweda.com 

※ 官方淘宝店：http://shop36920890.taobao.com 

 
 

专注于微波、射频、天线设计人才的培养 

官方网址：http://www.edatop.com 易迪拓培训 
淘宝网店：http://shop36920890.taobao.com 


